Build errors

Aug 30, 2011 at 8:59 PM

I get these three errors when I try to build the sources.

Error 6 The tag 'RippleEffect' does not exist in XML namespace 'http://schemas.microsoft.com/expression/2010/effects'. Line 62 Position 16. D:\dev\3rdparty\build\LogViewerForLog4Net\About.xaml 62

 

Error 7 The tag 'Interaction.Behaviors' does not exist in XML namespace 'http://schemas.microsoft.com/expression/2010/interactivity'. Line 305 Position 16. D:\dev\3rdparty\build\LogViewerForLog4Net\Window1.xaml 305

 

Error 8 The type 'ee:RippleEffect' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built. D:\dev\3rdparty\build\LogViewerForLog4Net\About.xaml 62

Coordinator
Sep 1, 2011 at 2:46 PM

Are you using VS2010 + all sp and last wpf toolkit ?

Developer
Sep 2, 2011 at 7:12 PM

Did you ever figure this out.  I'm having the same problem.  I downloaded and installed the WPF Toolkit from here: http://wpf.codeplex.com/ and it still wont work. 

I'm missing three references:  Microsoft.Expression.Effects, Microsoft.Expressions.Interactions, and System.Windows.Interactivity

Sep 2, 2011 at 8:55 PM

I am using VS2010 SP1, Windows 7 64 bit Ultimate SP1

I used the WPF Toolkit that is in the release.

I turned out I was missing some references to log4net, Microsoft.Expressions.Effects, Microsoft.Expressions.Interactions, System.Windows.Interactivity and WPF.Themes.

Now I get this error:

C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1360,9): warning MSB3247: Found conflicts between different versions of the same dependent assembly.C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.WinFX.targets(269,9): error MC1000: Unknown build error, 'Cannot resolve dependency to assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' because it has not been preloaded. When using the ReflectionOnly APIs, dependent assemblies must be pre-loaded or loaded on demand through the ReflectionOnlyAssemblyResolve event.' 

it looks like I mixed up some net framework versions somewhere

 

You need to install Expression Blend SDK if you haven't already: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=F1AE9A30-4928-411D-970B-E682AB179E17&displaylang=en 

And the default location for System.Windows.Interactivity is: 

C:\Program Files\Microsoft SDKs\Expression\Blend 3\Interactivity\Libraries\Silverlight